Update the devices to get better Security on your devices

Compass needle pointing the word security. Concept image blue and black tones

Bugs are the most irritating thing in the software and you must know that OS is also software they are also affected by the bugs. so you must update the software in order to get great performance.

Apple

Apple released hit the bug the problem with their OS update in MAC sierra  High Siera

including builds: –

17G6030 for macOS High Sierra version 10.13

16G1918 for macOS Sierra version 10.12

NOt only on MAC the company has also work on Watch OS with a major security update in apple series 1 and later variants. Security flaws were primarily in the kernel of WatchOS 5.2

Google

Google also compete in the race for bug tracking and eliminating with their security update. The monthly update for April fixed a lot of vulnerabilities and services in android which includes serious remote code execution (RCE) flaw, privilege escalation, information disclosure, and denial-of-service flaws. The most affected variant was android 7 and it’s variant. The Qualcomm components which are used by most of the android contained a lot of bugs.

Therefore YOu must update your phone if you are suffering from the bugs.

for more details- https://source.android.com/security/bulletin/2019-04-01.html

Ubuntu – The powerful and fast operating system has also some vulnerabilities in their kernel. Ubuntu also remedied the flaws found in Firebird and Dovecot applications.

1.USN-3933-2: Linux kernel (Trusty HWE) vulnerabilities: The vulnerabilities found in Bluetooth mode were terminated.

2.USN-3933-1: Linux kernel vulnerabilities: information disclosure (ID) and use-after-free in Bluetooth implementation which are resolved in an update.

3.USN-3932-2: Linux kernel (Xenial HWE) vulnerabilities: security issues with respect to AWS kernel as well as Xenial’s Hardware Enablement Kernel (HWE) were resolved to prevent an attacker from launching Dos and RCE attacks by exploiting the holes.

4.USN-3929-1: Firebird vulnerabilities: The Firebird database incorrectly handled certain malformed packets and UDF libraries leading to a DoS, and RCE flaw respectively. It exists in Ubuntu 14.04 LTS.

5.USN-3930-2: Linux kernel (HWE) vulnerabilities: HWE kernel and the kernel for Microsoft Azure in Ubuntu 18.04 LTS had numerous ID flaws.

6.USN-3930-1: Linux kernel vulnerabilities: Linux kernels for AWS.

VMware

VMware has published two major updates last week to address different security flaws in the product.

VMSA-2019-0005: VMware ESXi (versions 6.7, 6.5, and 6.0), Workstation (versions 15.x and 14.x) and Fusion (11.x and 10.x) had out-of-bounds read/write vulnerabilities that could allow RCE.

VMSA-2019-0004: A critical remote session hijacking flaw was affecting vCloud Director (versions 9.7.x, 9.5.x, 9.1.x and 9.0.x). Attackers could impersonate users by exploiting this flaw.

Harpal News
We have named our organisation “Harpal News”, It's not just about News! It's about Knowledge. Our main motive is to provide the latest technological news.